Announcement

Collapse
No announcement yet.

ZZR1100 Mr Turbo

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Do you plan on putting the fairings back on?
    I have neither the time,or the inclination, to explain myself to a man, who rises and sleep under the blanket of the very freedom that I provide, and then questions the manner, in which I provide it. I'd rather you just say 'thank you' and go on your way.

    Comment


    • #32
      Yes , 95% sure it will be original colour , will be fitting the screen I had on my other ZZR , had that on the road and looked death in the face for 10 odd years
      Being a dark tinted screen you can't see the pic , unless your looking through it !
      Attached Files

      Comment


      • #33
        Pulling my hair out today , put oil in engine , turned engine over to see if there was a spark , no spark
        Then noticed oil poring out bottom of engine , wtf
        Thought I got some pipes the wrong way around , took pipes off to turbo and replaced them with clear plastic so I could see oil flow direction , tried again , oil still pouring out
        Took filter out had a look , 0 ring was new and good , replaced it and tried again , oil still coming out !!
        Then noticed the oil filter cover was not seated all the way ,
        Took filter off again , and lucky for me still had the old one , new filter was a diffrent size , thank you Champion you little
        Did manage to get 6 pots on .
        May look at spark issue tomorrow !
        Attached Files

        Comment


        • #34
          Wired up the 2 rad fans today , not much room in there , only had one on the right hand side , can't remember the bike getting hot , but wired in a second one , front of the rad !
          Attached Files

          Comment


          • #35
            Still waiting on Oil filter , have emptied fuel tank of the old fuel , tank still looks new inside !
            Attached Files

            Comment


            • #36
              You're going to have to post a video when you get that thing running
              I have neither the time,or the inclination, to explain myself to a man, who rises and sleep under the blanket of the very freedom that I provide, and then questions the manner, in which I provide it. I'd rather you just say 'thank you' and go on your way.

              Comment


              • #37
                Yes that's the plan , Oil filter is on now , looks well made , just waiting on some fuel injection cleaner , need to bolt tank on , add fuel and cleaner , then check for leaks , as there is quite a few joints in the system !
                One reason the ZZR was on the back burner , turn your Volume up , engine in the clip has been replaced now , for a better one

                Attached Files

                Comment


                • #38
                  Was hoping to start it today , but a few issues , think they are sorted now , think the injection side is working now as it should

                  Last edited by residentalien; 11-16-2020, 10:57 AM.

                  Comment


                  • #39
                    Originally posted by residentalien View Post
                    Yes that's the plan , Oil filter is on now , looks well made , just waiting on some fuel injection cleaner , need to bolt tank on , add fuel and cleaner , then check for leaks , as there is quite a few joints in the system !
                    One reason the ZZR was on the back burner , turn your Volume up , engine in the clip has been replaced now , for a better one

                    My favourite race car from the sixties, next to the Ford Galaxy 500

                    Comment


                    • #40
                      Originally posted by YYCZED View Post

                      My favourite race car from the sixties, next to the Ford Galaxy 500
                      Sorry to say the Ford Galaxy left the jags standing , but then we had the MK1 Lotus Cortina and of course Jim Clark

                      Comment


                      • #41
                        Can't get the engine to start ,
                        Anyone know if I have the 3 wires right , going to the silver control box , Red live , Black earth , yellow too enrichment button , other side too earth
                        Battery is from car fully charged
                        Have spark
                        injectors are working
                        have cleaned them all have fine mist
                        Have fuel pressure
                        Must be a fuel issue , as the plugs are dry , with all the cranking would have thought they would be wet
                        Have not touched engine , or timing from last time engine run , just replaced old things for new , only big thing I have changed is the stick coils , but they are all working fine big fat blue spark , on a dry plug
                        Attached Files

                        Comment


                        • #42
                          May be too rich



                          Comment


                          • #43
                            Just a weeeee bit

                            Should be a simple enough fix.
                            I have neither the time,or the inclination, to explain myself to a man, who rises and sleep under the blanket of the very freedom that I provide, and then questions the manner, in which I provide it. I'd rather you just say 'thank you' and go on your way.

                            Comment


                            • #44
                              You would think so , but still a non starter , have strong spark , and fuel , just will not start , even with easy start , starting to think it may be low on compression , getting a few back fires in the exhuast , thought the too much fuel maybe because the injectors inject fuel , soon as you turn ignition on , so with me keep trying to start it , fuel is injected into the bores , plus there is not a spark till the engine is cranking fast , so I put a on off switch too the live feed , when engine is spinning I turn the power on to injectors , makes no diffrence , do have good fuel pressure , it's a mystery ZZR1100 Mr Turbo , injectors - YouTube

                              Comment


                              • #45
                                Big step forward today , my dad suggested I change the spark plug's , even thou I have a nice blue spark !
                                changed the 4 out like in the pic , and replaced them with Iridium plugs , spare for my Busa , they spark a more deep purple then blue
                                Any way engine will run , but only with easy start , the change of plugs has stopped the back firing in the exhuast and engine run's smooth , till the easy start run's out .
                                So now going to re look at the fuel side of things !
                                Attached Files

                                Comment

                                Working...
                                X